Kibana charts/dashboards not rendering on mobile


(Priyanka Raina) #1

I'm new to ELK and was trying to view some existing Kibana charts and dashboards, on a mobile platform (android/iOS/windows).

The charts are embedded within a web application but when accessed on mobile, only the placeholder shows up, the charts themselves being completely blank.

I'm not sure if this is because the rendering engine in mobile browsers is lighter compared to PC browsers, or if it is a configuration-related issue on the ELK server side.

Would appreciate any advice!


(Lee Drengenberg) #2

Hi,

There's a couple of things we can check, but here's the list of officially supported browsers;
https://www.elastic.co/support/matrix#show_browsers

Are you using those on the mobile devices?

What version of Kibana are you on?

When you say "The charts are embedded within a web application", can you access Kibana on the mobile devices and see the charts OK, but in some other web application you don't?

These pages might be relevant, specifically the cors settings;
https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-http.html

Thanks,
Lee


(Priyanka Raina) #3

Hi Lee,

Thanks for your reply.

I've tried a few mobile browsers - Apple (Safari, Mozilla), Windows (IE), Android (Chrome) - doesn't work on any.
Using Kibana v 4.4.2

Just to clarify the next bit, there's three scenarios -

  • Directly accessing the Kibana server to view the charts/dashboards on mobile browser - this doesn't work at all. I use the fully qualified URL like http://servername/ and that takes me to the default landing page (Red Hat Enterprise Linux Test Page) but once I add the port number to the URL like http://servername:portnumber and go, a time out occurs while it tries to load

  • Directly accessing a web server that has the kibana charts embedded on mobile browser - the rest of the web page shows up together with the placeholders for the charts but the charts themselves are blank

  • Directly accessing a web server that has the kibana charts embedded on PC browser, but via VPN - also doesn't work, same result as above

The only scenario that works is being directly connected to the network and using a PC browser.

Cheers!
Priyanka


(Lee Drengenberg) #4

Hi Priyanka,

I would suggest focusing first on accessing Kibana using the http://servername:portnumber either through the VPN or on the mobile devices.
Are you actually accessing the Kibana server or is there a proxy between you and Kibana?

Were you able to check the CORS settings in your Elasticsearch configuration? There's quite a list of connection issues related to these settings and there was a change in recent builds of Elasticsearch related to it. See some of these issues;

Thanks,
Lee


(system) #5