Kibana chkconfig startup error

kibana-5.2.1-linux-x86_64]# chkconfig --add kibana
kibana-5.2.1-linux-x86_64]# service kibana start
which: no node in (/sbin:/usr/sbin:/bin:/usr/bin)
unable to find usable node.js executable.

if I run ./kibana it runs perfectly. I am just trying to add it to service so that I can stay in background.

please anyone can assist on this.

hi @deepunaren,

to run as a service, it is probably easy to start with the debian package. Here's a step-by-step Running kibana as a service on Linux. That will take care of the hoisting the node-runtime for you.



Thanks for the Reply, I try using rpm which you suggested. but I still facing same issue.

Loaded plugins: security
Setting up Install Process
Examining kibana-5.2.1-x86_64.rpm: kibana-5.2.1-1.x86_64
Marking kibana-5.2.1-x86_64.rpm to be installed
VMwareTools5-5 | 951 B 00:00
ol6_custom_x86_64 | 951 B 00:00
ol6_radia | 951 B 00:00
ol6u7_base | 3.7 kB 00:00
ol6u7_updates | 951 B 00:00
Resolving Dependencies
--> Running transaction check
---> Package kibana.x86_64 0:5.2.1-1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

Package Arch Version Repository Size

kibana x86_64 5.2.1-1 /kibana-5.2.1-x86_64 141 M

Transaction Summary

Install 1 Package(s)

Total size: 141 M
Installed size: 141 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
which: no node in (/sbin:/usr/sbin:/bin:/usr/bin)
unable to find usable node.js executable.
error: %pre(kibana-5.2.1-1.x86_64) scriptlet failed, exit status 1
Error in PREIN scriptlet in rpm package kibana-5.2.1-1.x86_64
error: install: %pre scriptlet failed (2), skipping kibana-5.2.1-1
Verifying : kibana-5.2.1-1.x86_64 1/1

kibana.x86_64 0:5.2.1-1


hmm, I'm not sure what's what.

  • Did you modify the install scripts ('') at all?
  • what OS are you on? I tried on Ubuntu 16, which is fine.
  • How does your /usr/bin folder look like? Is there a node executable there?


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.