Kibana - Controls - Fuzziness/Case sensitive

There is a way to add fuzziness/Case sensitive in my controls in Kibana? Because when I type "a" no results are presented, but if I type "A" the results appears.
Any idea?
Thank you,

Hey @Francisca_Lima, are you referring to the behavior of the query/filter bar displayed below?

No, it's in controls visualization.

@Francisca_Lima, the controls visualization works with "aggregatable" fields, and is tied to the way that the field is stored in Elasticsearch itself.

When storing a string in Elasticsearch, we have a choice between storing it as "text" which allows you to perform free-text search and a "keyword" which is by default aggregatable. is a good article on this topic.

When determining which values to display in the Controls visualization, we perform a terms aggregation on the specified field. By default, we can only do so against a "keyword" field, and in this situation there is no analysis or normalization done on the strings which are being indexed, and as such there is no support for "fuzziness". It's possible to specify a normalizer for a "keyword" field which can be used to turn convert everything to lower-case to improve this situation.

It's also possible to enable fielddata for a "text" field, which will allow us to perform a terms aggregation on all of the tokens within the analyzed text, which could potentially be useful for your situation as well.

Thank you for the explanation! Very helpful!

Meanwhile one question came up: even transforming a "text" field with analyser, only "keyword" fields can be used in controls visualization? I tried to add an analyser to the "text" field, but this "text" field do not appear in controls visualization. I tried to add an analyser to the "keyword" field, however my search was not improved (some results even do not appear).

You can use a "text" field with fielddata enabled with the controls visualization.

Thank you! However this does not solve my problem because I have more than 1 word and I want to improve search query, to easily type some letters and appear the results (keywords/more than one word, like a name) that have the same letters.
The fielddata separate each word individually.

This is strange because if I type in controls (using a keyword field) sometimes the results appears but other times they do not but they exist. Using the filter bar above, doing the same thing, the result appears.

In another attribute, year of a date, something strange happens:
If I type in controls, the result does not match, but typing in filter bar, the results match.

Any idea? Controls does not work properly?

1 Like

The "Controls" visualization is not a direct replacement for the filter bar, and it offers a limited subset of this functionality. If you're looking for true fuzzy search, you'll have to continue using the filter bar.

Thank you. I though that controls were a more user friendly way to use filter bar.
That it an disadvantage, because if it is limited, I never know if I am transmitting wrong information to the person that it is using the dashboard.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.