Kibana "Discover: "***" is not a configured pattern


#1

kibana 5.4.1を使用しています。

kibanaを起動すると、
"Discover: "AAA" is not a configured pattern. Using the default index pattern
とワーニング表示されてしまいます。

index(AAA)は、elasticsearchには存在していませんし、
kibanaにも登録していないため、Discoverのindex一覧や、index patternsにも登場していません。
なぜ、このような表示がされるのでしょうか?

確かに、以前、index(AAA)のindexは存在していたこともあるのですが、
elasticsearchのindexを全て削除し、再構築した際には、該当のindex(AAA)は登録していないのです。
kibanaに登録されていたindex(AAA)が残っているのでしょうか?
もし、そうであるならば、削除する方法を教えて頂けないでしょうか?


(Jun Ohtani) #2

AAAを登録していたIndex Patternが残っている場合であれば、そのIndex Patternをリフレッシュするとどうでしょうか?
あとは、ワーニングの詳細やログにはどういった文言が出ているでしょうか?


(tsgkdt) #3

たとえば、Discoverの画面にお気に入りやショートカットからアクセスしてないでしょうか?

URLに表示させたいindexをパラメータで渡していますが、ここにKibanaのIndex Pattensに存在しないものを渡すと、
上記のような状況になるようです。

http://xxx.xxx.xxx.xxx:5601/app/kibana#/discover?_g=(refreshInterval:(display:Off,pause:!f,value:0),time:(from:now-1y,mode:quick,to:now))&_a=(columns:!(_source),index:ここに存在しないIndex,interval:auto,query:(query_string:(analyze_wildcard:!t,query:'*')),sort:!('@timestamp',desc))

このため、お気に入りやショートカットから開こうとされているのかと考えました。

再現手順

似たようなログを画面に表示させた場合の再現手順は以下の通りです。

  1. 2つElasticsearchにIndexを作成します。 forum0915, ともう1つ。
  2. KibanaのManagement - Index Patternsより作成した2つを追加します。
  3. KibanaのDiscoverでforum0915を表示します
  4. KibanaのManagement - Index Patternsよりforum0915を削除します
  5. KibanaのDiscoverの画面にメニューより遷移します
  6. 上部にWARNINGログが表示されます。

Discover: "forum0915" is not a configured pattern. Using the default index pattern: "forum0915_****"

なお、有効なIndexが1つ以上ないとDiscoverを開いたときに違うエラーとなるため、1の手順で2つIndexを作成しています。

確認した環境

Elasticsearch, Kibana: 5.4.1


#4

まさに、これでした。。。orz
お気に入りから開いていたため、不要なパラメータが渡されていました。

ありがとうございました。


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.