Kibana Discover view is very slow after upgrade - not compressing HTTP responses

We have updated from 7.4.0 to 7.13.2 a few days ago. Performance in Discover view has greatly deteriorated.

Query times are still good. Problem seems to be the long time it takes to render page:

  • Query time: 1.3 sec
  • Time to render full page: 31.sec

I checked response headers. Kibana is no compressing the response queries - as explained in topic 'Kibana not compressing HTTP responses'

Is this issue fixed in 7.13.2? Do I have to update any settings in Kibana?

Thanks,
Jorge

this might not be related. but I had this unusal slow opration of kibana for everything and anything on it.

Turn out that they have turn on fleet by default. ( I believe that was from 7.12+)
and that means your kibana is trying to go out and update fleet and if you don't have internet connection it is just spinning for long time.

disable fleet on kibana
xpack.fleet.enabled: false

Again this might not be the case in your situation.

Hi Sachin,
I'm afraid adding fleet setting didn't help.

It is clear to me the reason Discover view in 7.13.2 is slower than in 7.4.0 is because the size of the response is much bigger, since it doesn't use 'gzip' for content encoding.

Is this the expected behavior now? Or is there a way to improve response times in Discover view?

Thanks!

Looks like the fix, https://github.com/elastic/kibana/pull/97994, has been merged into 7.14 branch. I am not sure if this fix will be backported to 7.13.

Thanks for the information Nathan. It is very helpful.
I guess we’ll have to wait for 7.14 release.

To improve performance of Discover View I have updated setting 'Number of rows' (discover:sampleSize) in Advance Settings. Default value is 500 - new value 50.
This reduce response time from 31 seconds to only 7 seconds :grinning:

I suppose time reduced will depend on the size of the records - in our case documents are quite large.

Hi

Do you have many multi fields in your mappings? could you record and share a Chrome performance profile when loading Discover?
Many thx!
Best,
Matthias

Hi Matthias,
Yes, we do have many multi fields and we are working to reduce these.
Here you have details from Chrome when Number of Rows is set to 500:

elastic

thx, can you test, if performance gets better if you set discover:searchFieldsFromSource to on ? thx!

Hi Matthias,
There is a small improvement after setting discover:searchFieldsFromSource to on, as response size is smaller. However, discover view is still much slower than version 7.4.0.
For the moment we'll keep discover:sampleSize set to 50 till 7.14 is released. This give us decent performance.

Thanks!
Capture