Kibana docker image fails to run with FATAL "xpack.monitoring.ui.container.elasticsearch.enabled" setting was not applied error


(Shreyas Sangai) #1

I am trying to run the docker image : docker.elastic.co/kibana/kibana:6.2.4

Command used to run :
docker run -d -e "xpack.monitoring.enabled=false" -e "xpack.monitoring.ui.container.elasticsearch.enabled=false" --name kibana --restart always -p 5601:5601 docker.elastic.co/kibana/kibana:6.2.4

However, it fails to run and gives the following expection :
{"type":"log","@timestamp":"2018-09-28T08:04:05Z","tags":["fatal"],"pid":8,"message":"\"xpack.monitoring.ui.container.elasticsearch.enabled\" setting was not applied. Check for spelling errors and ensure that expected plugins are installed and enabled."}
FATAL "xpack.monitoring.ui.container.elasticsearch.enabled" setting was not applied. Check for spelling errors and ensure that expected plugins are installed and enabled.

xpack is disabled in elasticsearch container as well using the -e flag to disable xpack.


(Chris Davies) #2

If xpack is disabled, you shouldn't specify any xpack config values, as they won't be recognized.

e.g. Don't pass in -e "xpack.monitoring.enabled=false" -e "xpack.monitoring.ui.container.elasticsearch.enabled=false"


(Shreyas Sangai) #3

I tried this but I still get the same message.

Ran docker inspect elastic to check if xpack is actually disabled and it is. Here is the snippet :

  "StdinOnce": false,
            "Env": [
                "xpack.security.enabled=false",
                "PATH=/usr/share/elasticsearch/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin",
                "ELASTIC_CONTAINER=true",
                "JAVA_HOME=/usr/lib/jvm/jre-1.8.0-openjdk"
            ],

(Chris Davies) #4

Ah. I see. x-pack is enabled, but x-pack security is disabled. What version of Kibana are you running?


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.