Running Kibana on Docker Swarm: Settings for "elasticsearch" were not applied

I'm trying to get Kibana running on Docker Swarm using a compose file. I have a running Elasticsearch instance without XPack. I'm trying to just get the most vanilla installation running with minimal options.

My configuration looks like this:

      mode: replicated
      replicas: 1
      - "5601:5601"
      SERVER_NAME: "My Kibana"
      SERVER_PORT: "5601"

When I run this my logs show:

 "message":"Settings for \"elasticsearch\" were not applied, check for spelling errors and ensure the plugin is loaded."}
 "message":"Settings for \"xpack\" were not applied, check for spelling errors and ensure the plugin is loaded."}
 "message":"Server running at http://localhost:5601"}
 "tags":["status","ui settings","error"],"pid":1,"state":"red",
 "message":"Status changed from uninitialized to red - UI Settings requires the elasticsearch plugin","prevState":"uninitialized","prevMsg":"uninitialized"}

When I visit the web app I get:

    "statusCode": 404,
    "error": "Not Found",
    "message": "Unknown app kibana"

I can't find many references to these error messages.

Per Running Kibana on Docker | Kibana User Guide [5.6] | Elastic

X-Pack is pre-installed in this image. With X-Pack installed, Kibana expects to connect to an Elasticsearch cluster that is also running X-Pack.

But I'd hoped I could disable it. In any case, I'm not sure if this is pertinent to the first log error message.

Am I doing something wrong? Should I expect Kibana actually run on Docker out of the box without Xpack?

Per this Github issue, other people are having problems using the official Docker image.

I was able to get the deprecated Docker Hub Docker image working:

The Github issue you linked to has a workaround, which is to create your own custom image:

Essentially, the image is composed starting with the official image, but then un-installing the X-Pack plugin from Kibana.

If you're still having issues, I would recommend taking the discussion to that Github issue - it looks like that's the go-to issue.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.