Kibana doesn't have permissions


(imparker) #1

After installing x-pack to the current version of ELK, I am unable to change settings on the web interface for Security, watcher, or logstash. Can only manage index patterns which aren't showing anything, even though I configured packetbeat with logstash & kibana user & passwords.

Please me know what logs or yml's you might need to help troubleshoot this. Thank you.

ELK: 6.2.4
OS: Ubuntu 18.04 LTS


(Tim Vernum) #2

I don't entirely understand what you are reporting.
What sort of settings are you hoping to change through the web interface?


(imparker) #3

Sorry for the confusing language. The first thing I want to accomplish here is to have packetbeat be able successfully send information to logstash and for the ELK server to be able to receive it properly.

In regards to that, I have the ELK server configured with passwords correctly per the documentation, and I have packetbeat configured with the authentication for kibana & logstash, but no ssl. Do I have to enable SSL and then create the certs for that? What is the proper procedure for configuring packetbeat here.


(imparker) #4

Does packetbeat require you to use TLS when using xpack? How do I configure that? I couldn't find documentation for that.


(Tim Vernum) #5

It sounds like you want to have the following setup:

  1. packetbeat collects data
  2. packetbeat sends data to logstash
  3. logstash process data and sends it to elasticsearch
  4. kibana connects to elasticsearch to visualise packet data.

The first step is to work out which step is broken.
This could be a logstash->elasticsearch issue, but it could also be a problem with packetbeat->logstash.

What debugging have you done? What errors are you seeing?
It's hard to solve a problem that amounts to "it does work" with no specific details.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.