No access to kibana role management UI

Hello everyone,

I'm currently setting up the ELK-Stack + Filebeat and for the first configuration, I try to do without SSL as that was way too troublesome for a prototype when I first tried to implement it in every part of the stack.
After disabling the SSL-options, I don't have access to the role management in the Kibana UI anymore, as well as to the user settings in which I can log out.

In other, partly much older threads to this topic, I read about having to set up xpack (or at least the encryption keys) or disabling the monitoring.ui.ccs and I've at least done the latter two things (see censored entries in kibana.yml, has been generated externally), but I hardly found anything regarding the mandatory xpack-settings as the main settings are shipped with the kibana package since a few releases, if I understood correctly.
The cluster is active and yellow (due to a few unassigned shards) and I was able to run the filebeat and the logstash scripts. The latter had issues with a "Cannot get new connection from pool"-error which I hope to resolve by adding a filebeat-index via the UI, but that's probably a topic for another thread.

Here's my kibana.yml:

server.port: 5601 ""
elasticsearch.hosts: ["http://localhost:9200"]
elasticsearch.username: "kibana_accessor"
elasticsearch.password: "************"
monitoring.ui.ccs.enabled: false

xpack.encryptedSavedObjects.encryptionKey: *********
xpack.reporting.encryptionKey: ********** "************"

      type: file
      fileName: /var/log/kibana/kibana.log
	type: pattern
	highlight: true
    appenders: [default, file]
    level: warn

  - name: elasticsearch.query
    level: debug

pid.file: /run/kibana/

I haven't found any hints of an error in the kibana-logs or the journalctl-entries and I don't know how to copy logfile-contents into code-brackets here so in case the yml-file isn't sufficient, I'll add the log-contents later on.

Can someone please help me to regain access to the roles-management-UI? Which settings are required for that?

ETA: Could it depend on the user I start Kibana with? I tried all users I had, including root, as well as logging in with kibana_accessor and the elastic-superuser, but that didn't seem to make a difference.

Hi @Calvy93,

I can understand wanting to setup a simple cluster without encryption. In prior versions getting everything properly configured could be a headache, but that isn't really the case anymore. I'd recommend you go through the steps outlined in the documentation when setting up your (I'm going to assume here it's 1-node) cluster. You'll find that having the basics setup by the book will pay off later. Good luck.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.