Kibana error when enabling xpack security

Hi, i've look through the forums and found many people having errors when enabling xpack, but not exactly my error, if i enable xpack on elasticsearch it pops up the log in when i access the website, but when i enable it in kibana it refuses to start the service.

Picture of the error:

My kibana.yml

Thanks in advance.

There is nothing useful in the error log, you need to check in the system logs to see if there is more information.

But from your kibana.yml you have elasticsearch.password set twice, this won't work, you need to fix the kibana.yml and remove the duplicated entry.

Hi Leandro, i was following a tutorial and he also had duplicated entries and worked, since we were on the same version i thought it would work too, i will get rid one of the entries and get back to you asap.

So kibana service is running well but i am faced with an error page online:

Which tutorial? Is a tutorial from Elastic? You can't have duplicate keys on a yaml file.

Kibana runs on port 5601, not on port 8080.

I recommend that you follow the official guide from Elastic.

I was following this tutorial:

btw i am just gonna add what the kibana service status looks like

It was running well on 8080 before.

Just saw that you manually changed the port to use 8080.

Have you tried to access using http or https ? You need to use https:// not http.

I did change the port to 8080, turns out it was automatically filling the url with http and not https, it's working, thanks a lot.