Kibana gets wrong timezone from my browser


I have a deployment in Elastic Cloud (7.6) and Kibana doesn't get the correct timezone from by browser. I have to configure it to "Europe/Madrid" instead of "Browser", because if not, the dates I see are 1 hour out of phase. Why this can happen?

Thanks in advance!

I had the same issue, not sure if it is the same. Elasticsearch stores the timestamp as UTC if you don't specify it. then in Kibana translates that time into your browser.
For example, my server is at UTC+1. when the server sent the data to Elastic it was wrongly considered UTC, and when displaying in the browser because it was UTC+1 it would show one hour ahead.
What I did was to specify the timezone I was passing to Elastic as UTC+1, then it will convert it to UTC and translate in my browser the timezone I am.

In my case I store the data in Elasticsearch correctly in UTC. My browser is in UTC+1, so I expect to see the dates in Kibana in UTC+1, but it does not happen. Kibana shows dates correctly only if I configure the timezone to UTC+1 instead of "Browser".

I have another deployment of Elastic Stack 7.4 on-premise and it runs correctly.

I'm seeing the same effect. I got the data stored in elasticsearch in UTC. Kibana in the Discover Section shows UTC in the Time Column of the Table and UTC+1 (the bworsers timezone) in the event count graph. So it seems the time field does not respect the browser setting.

I'm running a fresh installation of ELK 7.6

I just found a bug report to that issue:

This is a universal issue in 7.6.0, that will happen to anyone and will be fixed in the next patch version. We're sorry for the inconvenience. The current workaround is to don't use the "Browser" timezone under Management > Advanced Settings, but setting this to a specific one.

1 Like

Thanks a lot @babelr!!!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.