Kibana is not displaying Marvel App Switcher


(Cameron Fillers) #1

I installed ElasticSearch/Kibana/Filebeat as part of a development server. All of that worked without issue, and am receiving data from 3 servers via Filebeat.

I am attempting to install Marvel and Sense for development purposes, and am running into issues with getting the App Switcher to show in Kibana. Currently, there is no icon, but Marvel and Sense are installed.

ElasticSearch shows the following status for Marvel...

"marvel" : {
"agent" : {
"exporters" : {
"id1" : {
"host" : [ "http://localhost:9200" ],
"type" : "http"
}
}
}
},
"action" : {
"auto_create_index" : ".marvel-*"
},
}, {
"name" : "marvel-agent",
"version" : "2.3.4",
"description" : "Elasticsearch Marvel Agent",
"jvm" : true,
"classname" : "org.elasticsearch.marvel.MarvelPlugin",
"isolated" : false,
"site" : false
} ],

Kibana shows this from command line when attempting to install Marvel again...

[root@elasticsearch kibana]# bin/kibana plugin --install elasticsearch/marvel/2.3.4
Installing marvel
Plugin marvel already exists, please remove before installing a new version

I have restarted both services but without success to access Marvel.


(Shaunak Kashyap) #2

After you install the Marvel plugin in Kibana and restart the Kibana server, what do you see in the logs? Would you mind pasting the log lines from point where you start the Kibana server to when it is listening ("Server running at...")?


(Cameron Fillers) #3

I following an install guide from DigitalOcean, which I found installed Kibana 5.4, as opposed to 5.5, which was the reason for it not showing the app icon.

I have since uninstall Kibana 5.4, and install Kibana 5.5 based off of this guide...

https://www.elastic.co/guide/en/kibana/current/setup.html

I uninstalled using yum, and removed the directory /opt/kibana, and updated yum, and installed using yum.

Now, when I start kibana, I get the following error from...

/var/log/kibana/kibana.stderr

Error: EACCES: permission denied, open '/opt/kibana/optimize/.babelcache.json'
at Error (native)
at Object.fs.openSync (fs.js:549:18)
at Object.fs.writeFileSync (fs.js:1156:15)
at save (/opt/kibana/node_modules/babel-core/lib/api/register/cache.js:35:19)
at nextTickCallbackWith0Args (node.js:420:9)
at process._tickDomainCallback (node.js:390:13)
at Function.Module.runMain (module.js:443:11)
at startup (node.js:139:18)
at node.js:968:3
fs.js:549
return binding.open(pathModule._makeLong(path), stringToFlags(flags), mode);

And unable to get kibana to start up and work normally.


(Cameron Fillers) #4

I followed the issues on this page...


and modified /etc/default/kibana and changed it to run as root:root

and chowned /opt/kibana to root:root and restarted. Still not able to access kibana on port 5601 in browser after restarting elasticsearch/kibana


(Shaunak Kashyap) #5

Do you see any errors in the Kibana log?


(Cameron Fillers) #6

There we none. I was on Centos 7, and since trying to update kibana there has been nothing but errors and issues. I decided to try a re-install on centos6 and just install ElasticSearch/Kibana, and then add in Marvel and Sense.

I'll provide feedback as soon as I am finished and let you know if it is resolved, or if I have further issues.


(Cameron Fillers) #7

Okay, I installed fresh from elastic.co, with a brand new ES/Kibana/Marvel/Sense, and restarted ES and Kibana, and everything is coming up as expected

I am unsure if the issue was with Centos 7, or from using the DigitalOcean guide, and attempting to install Marvel higher than Kibana allowed, requiring an upgrade of Kibana that just broke completely.


(system) #8