Kibana loading very slow after update to 4.3.1


(srinivas m) #1

I just updated my Kibana to 4.3.1 and I am facing some problems in kibana loading :

While configuring the index I have selected the option contains time-based events enabled.
The date format I am using an field present in the index having format "yyyy-MM-dd HH:mm:ss" and not default timestamp in latest version @timestamp : "strict_date_optional_time||epoch_millis"


(Lee Drengenberg) #2

Hi Srinivas,

What version of kibana were you on before this?

And did you just upgrade and use the same kibana index pattern or is it different now?

Does the Discover page ever load, or just keeps searching?

I don't understand this part of your question. Can you please explain more?;

@timestamp : "strict_date_optional_time||epoch_millis"

Thanks,
Lee


(srinivas m) #3

The previous version kibana we were using was 4.1.1
We just did the upgrade and I am using same index pattern.
Discover page loads after it is struck for around 5 mins.
While configuring the index there are two timestamp fields available as shown in the pic


INSERT_DATE: yyyy-MM-dd HH:mm:ss
@timestamp : "strict_date_optional_time||epoch_millis"

I have selected INSERT_DATE option. Is it causing the issue of loading.
In Previous version I was using the same INSERT_DATE it was not causing any issue


(Erik Stephens) #4

In 4.3, they started to use the elasticsearch field stats api to identify which indices to query against instead of using index glob patterns. Hopefully that points you in the right direction to trouble-shoot. Maybe this issue will be helpful.


(system) #5