kibana登陆被禁用(Login is currently disabled. Administrators should consult the Kibana logs for more details.)


(Little Five) #1

elasticsearch 版本6.2
kibana 版本6.3
均未安装使用x-pack插件
服务启动后,kibana提示:Login is currently disabled. Administrators should consult the Kibana logs for more details.

kibana日志错误内容:
log   [06:42:32.020] [warning][security] Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml
  log   [06:42:32.023] [warning][security] Session cookies will be transmitted over insecure connections. This is not recommended.

log   [06:42:32.393] [warning][reporting] Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failing on restart, please set xpack.reporting.encryptionKey in kibana.yml

 log   [06:42:32.432] [error][status][plugin:xpack_main@6.3.0] Status changed from yellow to red - This version of Kibana requires Elasticsearch v6.3.0 on all nodes. I found the following incompatible nodes in your cluster: v6.2.4 @ 172.17.91.21:9200 (172.17.91.21)

log   [06:42:32.476] [error][status][plugin:xpack_main@6.3.0] Status changed from red to red - X-Pack plugin is not installed on the [data] Elasticsearch cluster

log   [06:43:02.479] [warning][license][xpack] License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [invalid_index_name_exception] Invalid index name [_xpack], must not start with '_'., with { index_uuid="_na_" & index="_xpack" } :: {"path":"/_xpack","statusCode":400,"response":"{\"error\":{\"root_cause\":[{\"type\":\"invalid_index_name_exception\",\"reason\":\"Invalid index name [_xpack], must not start with '_'.\",\"index_uuid\":\"_na_\",\"index\":\"_xpack\"}],\"type\":\"invalid_index_name_exception\",\"reason\":\"Invalid index name [_xpack], must not start with '_'.\",\"index_uuid\":\"_na_\",\"index\":\"_xpack\"},\"status\":400}"}
-------------------------------------------------------------------------------------------------------------------------

之前版本:
elasticsearch版本6.2
kibana版本版本6.2
服务均未安装x-pack插件
可以正常启动和使用
把Kibana换成6.3后,kibana无法使用


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.