Kibana MAC oss version shows xpack error

I have an Amazon ES with 6.7.0. Recently migrated from 6.2.3 --> 6.7.0.
I have a separate Kibana instance talking to Amazon ES. I am trying to locally setup a kibana to connect to AmazonES (through aws-es-proxy).

I see this error:
log [01:48:52.120] [warning][license][xpack] License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. Authentication Exception :: {"path":"/_xpack","statusCode":401,"response":"{\"Message\":\"Your request: '/_xpack' is not allowed.\"}"}

And I am using kibana-oss-6.7.0-darwin-x86_64.tar.gz which shouldn't have x-pack

Hi there, Anirudh!

I've tried to replicate this issue locally and I am not having any luck. Be sure you're using the Kibana OSS download from this page.

Are you using separate Elasticsearch clusters for Kibana data and search data? For instance, are you using any of the elasticsearch.tribe.* settings in your kibana.yml file?