Kibana Maps- Configure Label Text so it is legible

Hi there using Kibana 17.9.2 and setting up a Maps widget. All great.. u,nti,l, ,yo,u, setup a label,., Totally illegible

Have played with colors and pixel sizing to no avail., Is there a way to set the font/and size for teh lable that I have missed?

This is a screen shot.... so you can see what I mean.

Many thanks in advance

Hi, the problem is that you have many geometries overlapping and currently Elastic Maps does not prevent labels to overlap or allow to choose between fonts. You can change the size of your labels but that won't help.

It would work better if you use the cluster layer type so your points are aggregated, then you can label the count or the most frequent label using the Top Terms metric.

Another option would be to duplicate your layer and only use labels for a certain subset of your data, but that will depend greatly on your use case.

Thanks Jorge. That kindda works in one way.. amd will help.
However, I am putting a system toigether which measures sensors on devices.... and I was hoping to use the label to state the location name of the device. The Big Picture will be upwards of 10k devices, and 33 Bn docs pa... so it wull be a 'tad busy' on the map, and allowing users to zero in to what they wanted would have been useful.

This will do to get the point across though.. Will, raise an issue in git at teh weekend... you never know..., even an 'Alias' type field with its own formatting would be useful.

It would be great to have your feedback and use case on github, please feel free to open a feature request there :+1:

1 Like

You could also try using top hits to only display the label for the most recent data point for an entity.