Kibana no longer works (6.4.0)

We have run through incremental upgrade on our test cluster.
Everything seems to be working fine, except Kibana.
I am able to start it. It seems to connect fine and even receive data, according to log.
However I am no longer able to access the web kibana dashboard...
It is set up with TLS in place. and if I put 6.3 with the same config it works just fine.

Also my Monitoring cluster reports that kibana is aliveand kicking.

Below is my kibana config:

server.port: 5601

elasticsearch.url: ""
elasticsearch.username: SECRET_ID
elasticsearch.password: SECRET_PASSWORD

console.enabled: true true
server.ssl.enabled: true
server.ssl.certificate: /etc/kibana/certs/
server.ssl.key: /etc/kibana/certs/

elasticsearch.ssl.certificateAuthorities: [ "/etc/kibana/certs/company-root-ca-g3.pem" ]

server.ssl.certificateAuthorities: [ "/etc/kibana/certs/company.root.pem" ] RANDOMLY_GENERATED_STRING_THAT_IS_VERY_LONG

my used to be ::0 before and worked just fine, however with 6.4 it would not let kibana start, saying connection was refused. So i changed that to

Elasticsearch on its own works as expected still.... all hosts are alive and whatnot.

Please help T_T

Are you trying to access Kibana from localhost? If not, you'll want to set to the machine's public ip.

1 Like

Thank you! this have worked!

also setting it to also worked - in case anyone else needs to do that :slight_smile:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.