Kibana not connecting to elasticserach after adding tls/ssl and https


(Rajeshwer rao Madoori) #1

Kibana unable to connect to elastic search

ERROR

`{"type":"error","@timestamp":"2018-10-31T20:46:20Z","tags":["connection","client","error"],"pid":1,"level":"error","error":{"message":"socket hang up","name":"Error","stack":"Error: socket hang up\n    at TLSSocket.<anonymous> (_tls_wrap.js:876:25)\n    at emitOne (events.js:121:20)\n    at TLSSocket.emit (events.js:211:7)\n    at _handle.close (net.js:567:12)\n    at Socket.done (_tls_wrap.js:356:7)\n    at Object.onceWrapper (events.js:315:30)\n    at emitOne (events.js:121:20)\n    at Socket.emit (events.js:211:7)\n    at TCP._handle.close [as _onclose] (net.js:567:12)","code":"ECONNRESET"},"message":"socket hang up"}

`

`  kibana.yml: |
server:
  name: "kibana"
  host: 0.0.0.0
  port: 5601
elasticsearch.url: "https://es-coordinating:9200"
xpack.security.enabled: true
server.ssl.enabled: true
server.ssl.key: /usr/share/kibana/config/tls_server/tls_server/key.pem
server.ssl.certificate: /usr/share/kibana/config/tls_server/tls_server/crt.pem
elasticsearch.ssl.certificateAuthorities: /usr/share/kibana/config/certs/CA.crt
elasticsearch.username: elastic
elasticsearch.password: xxxx`

(Nick Peihl) #2

Hi Rajeshwer,

Do you see any errors in the elasticsearch logs? This might mean that SSL isn't working on the elasticsearch side. Can you share your elasticsearch.yml configuration?


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.