Kibana not displaying fields with more than 300 characters

Hello ,

I'm using kibana to display log messages that have more than 300 characters .I already modified the "ignore_above" parameter in the mappings.
I've done some tests manually :
string : length =295 characters => displayed in kibana (data table)
string : length =305 characters => not displayed in kibana (data table)

BTW : In discover menu the field is displayed for the long messages.

Any help would be appreciated,
Best Regards,

I wonder if you're running into truncate:maxHeight. Can you try updating that in advanced settings?

I have set truncate:maxHeight to 0 (disabled it).

For info , I initially couldn't visualize the lines containing long fields in the data table so I did the following steps : add-sub-bucket ->advanced ->json-input -> added this text : {"missing":"N/A"}.
So now , I get the missing lines displayed but for the long field I get 'N/A' displayed.
Whats intriguing for me is that these values exist in my ES index , but not displayed in kibana.

Any ideas? (I'm using kibana 5.5)

Thanks in advance
Best regards ,

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.