Kibana not seeing external ES monitoring node

Hi all,
yesterday I setup a dedicated single monitoring node following this guide.

I managed to fire up the new monitoring node with the same ES 6.6.0 version of the cluster, then added those lines to my elasticsearch.yml file on all ES cluster nodes :

 type: http
  host: ["http://monitoring-node-ip-here:9200"]

Then restarted all nodes and Kibana (that is actually running in one of the node of the ES cluster).

Now I can see today monitoring data indices being sent to the new monitoring external node but Kibana is showing a "You need to make some adjustments" when accessing the "Monitoring" section.

We checked the  `cluster defaults`  settings for  `xpack.monitoring.exporters` , and found the 
reason:  `Remote exporters indicate a possible misconfiguration: id1`

Check that the intended exporters are enabled for sending statistics to the monitoring cluster, 
and that the monitoring cluster host matches the  `xpack.monitoring.elasticsearch`  setting in  
`kibana.yml`  to see monitoring data in this instance of Kibana.

I already checked that all nodes are pingable each other , also I don't have xpack security so I haven't created any additional "remote_monitor" user.

I followed the error message and tried to add the xpack.monitoring.elasticsearch in kibana.yml file but I ended up with the following error :

 FATAL  ValidationError: child "xpack" fails because [child "monitoring" fails because [child 
"elasticsearch" fails because ["url" is not allowed]]]

Hope anyone can help me in figuring what's wrong.


Solved : problem was due to monitoring not being disabled in the monitoring cluster :

PUT _cluster/settings
  "persistent": {
    "xpack.monitoring.collection.enabled": false

Additional I made a mistake in kibana.yml configuration,
xpack.monitoring.elasticsearch should have been xpack.monitoring.elasticsearch.hosts

Could you mark this topic as solved? Thanks!

Done, thank you for you great piece of software :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.