Kibana only displaying certain ip address from csv file

I am posting a csv file directly to elasticsearch and Kibana only displays certain ip addresses. Below might explain better.

csv file:

id,IP,Hostname,OS,Scan Start,Scan End,CVSS,Severity,High,Medium,Low,Log,False Positive,Total

Out of these three id's, Kibana only displays the IP addresses in which the last octet starts with 2. and are displayed but not Additionally, are shown but not This is why I believe it is the last octet of the IP address but have zero idea as to why this might be occurring.

Thanks in advance..

Hi @bm1391,

I require some additional information about your setup in order to provide assistance. Which version of the Elastic Stack are you using? When you say "posting a csv file directly to elasticsearch", what does that mean? What do the documents in Elasticsearch look like?

Sure, Here is the additional information:

Elasticsearch version number: 2.4.6
Kibana Version: 4.5.4

I have posted the csv file to Elasticsearch with curl command in python. Here is the python command:
This just reads my csv file(ready.csv) and puts the values into Elasticsearch.

--csv-file ready.csv
--elastic-path "$HOSTNAME/file/%id%"
--json-struct '{
"IP" : "%IP%",
"Hostname" : "%Hostname%",
"OS" : "%OS%",
"Scan Start" : "%Scan Start%",
"Scan End" : "%Scan End%",
"CVSS" : "%CVSS%",
"Severity" : "%Severity%",
"High" : "%High%",
"Medium" : "%Medium%",
"Low" : "%Low%",
"Log" : "%Log%",
"False Positive" : "%False Positive%",
"Total" : "%Total%"

This is what I see when I query for the indices in Elasticsearch: You see 254 for 254 ip addresses from the CSV file:

yellow open globex-network 5 1 254 0 243.8kb 243.8kb

CSV file: (There are 254 lines)

id,IP,Hostname,OS,Scan Start,Scan End,CVSS,Severity,High,Medium,Low,Log,False Positive,Total

This is what I see in Kibana on the Discover page:

But when I go to visualize the data, I can only see a certain amount of them:

The "size" setting on your x-axis "Terms" aggregation influences the number of terms that are displayed. It defaults to 5, but you can increase it in the aggregation settings on the left side of the visualization editor.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.