Kibana - Plugin:elasticsearch@6.2.3 Service Unavailable (Kibana unable to connect to Elasticsearch)

Hi, I am a beginner in elasticsearch, I installed elasticsearch 6.2.3 and kibana 6.2.3 on a machine (master) centos 6.9 minimal, and I want to access the kibana by another machine windows 7.

  1. machine (master) when elasticsearch and kibana are installed :
  • network configuration (eth0):


  • elasticsearch configuration : cluster_hadoop_chu master
node.master: true false /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
bootstrap.system_call_filter: false localhost
transport.tcp.port: 9300
http.port: 9200
discovery.zen.minimum_master_nodes: 3
  • Kibana configuration : ""
elasticsearch.url: "http://localhost:9200"

  1. machine (windows 7) when I want to access to kibana by browser :
  • Network configuration :


  • Elasticsearch :

when I type on chrome '' it works fine

  • Kibana :

but when i type on chrome '' that's what shows me :

please help me, I searched too much on google and I have not found a solution yet.

pinging @tylersmalley for more advice on this.


I do not understand your config. If you are just starting out with Elasticsearch, I would recommend you start with the default options.

I can see a few potential issues with your config:

  • All clusters need at least one data node. The node you are showing has set to false.
  • You have set discovery.zen.minimum_master_nodes to 3, indicating that you expect 4-5 master eligible nodes in the cluster if you have been following these guidelines.
  • If you are expecting other nodes, you have not configured discovery so that you node can find these other nodes.

I have just 1 cluster with 1 node (single node) it's the machine when I installed elasticsearch and kibana but I have centos 6.9 minimal in this machine and I want to access to kibana by browser chrome in the other machine (windows 7)

In that case, you should address Christian's feedback. One way would be to remove the following from the config: master
node.master: true false
bootstrap.system_call_filter: false
discovery.zen.minimum_master_nodes: 3
1 Like

thank you very much the problem is solved :grinning:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.