Kibana Plugin Installation Fails

Hi, currently I have Kibana 7.10.0 ,I am trying to install logtrail plugin.I have followed documentation and changed Kibana version inside package.json correctly zipped again but when I install it throws following error.

Attempting to transfer from file:///tmp/logtrail/build/logtrail-0.1.31.zip
Transferring 7388992 bytes....................
Transfer complete
Retrieving metadata from plugin archive
Plugin installation was unsuccessful due to error "No kibana plugins found in archive"

First I tried zip file under releases section of logtrail then I even build it from source with yarn.But no luck same error pops up.

zip folder structure is like following:

logtrail-0.1.31.zip
  kibana/
  └── logtrail
      ├── index.js
      ├── logtrail.json
      ├── node_modules
      ├── package.json
      ├── package-lock.json
      ├── public
      ├── server

Even tried other plugins but it throws same error.Example:
bin/kibana-plugin install https://github.com/pjhampton/kibana-prometheus-exporter/releases/download/7.10.0/kibana-prometheus-exporter-7.10.0.zip

Any Ideas? what can be reason?

It's probably related to this part of the release notes from 7.10.0;

Platform

  • The legacy plugin system and the legacy plugin API have been removed. It is no longer possible to use third parties legacy Kibana plugins. Legacy plugin owners should migrate their plugins to the Kibana Platform plugin API #77599

Oh, I have almost spend a day with this ). Okay any workaround?

No it doesn't look like it.

So problem is different yes? and we dont know what?

So problem is different yes? and we dont know what?

As already mentioned in the thread: the plugin must migrate to the Kibana platform architecture. There is a migration guide with examples

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.