Kibana PUT request timing out

Hello All,

I am running an Elastic search and Kibana 6.1.1 on Kubernetes with docker containers. I have configured s3-repository plugin for backup.
I am trying to create a backup from Kibana of indice with size 5gb:

         PUT /_snapshot/s3_repository/snapshot_1?wait_for_completion=true&pretty
    {
      "indices": "INDICE_NAME",
      "ignore_unavailable": true,
      "include_global_state": false
    }

However, after maybe 30sec, I get an error saying:

"statusCode": 504, "error": "Gateway Time-out", "message": "Client request timeout"

I get the same error while trying to delete a snapshot from s3 as well.

Is there a way we can mention or increase the timeout time while doing the PUT request in Kibana?

Thanks

Hi @awstrain34,

Usually a 504 comes from some kind of a proxy that you may have in front of Kibana/Elasticsearch. Do you still see this error if you make this request to Elasticsearch directly without using Kibana DevTools (e.g. with cURL)?

Best,
Oleg

Hello @azasypkin,

Yes, there is a proxy running in front of Elasticsearch and Kibana. I will run the request as a curl command and will see how that goes.
Thanks for your reply.

Thank you @azasypkin. It worked.