Kibana Report & API 405 Error


(Christopher Brown) #1

Hi

I have Kibana 5 up and running with a single fairly simple dashboard. When I navigate to the generation URL, I am getting a 405 Error:

{"statusCode":405,"error":"Method Not Allowed","message":"GET is not allowed"}

I am sure its probably just a config option set incorrectly. If I try the printable PDF its says URL not valid, which I am guessing is the same issue.

I am running Kibana on Windows, just in case that has a impact.

Any help welcomed.

Thanks

Chris


(CJ Cenizal) #2

Hey Christopher,

That generation URL needs to be requested using POST, not GET (i.e. it can't be accessed by navigating to it in the browser). This is because it's intended for automatic report generation: https://www.elastic.co/guide/en/reporting/current/getting-started.html#automating-report-generation

To manually generate the report, you have to click the "Generate Printable PDF" and wait for the report to be generated.

I think this UX is a little confusing too, so I've created an internal issue to improve this a bit and make it more intuitive.

Please let me know if you have any more questions.

Thanks,
CJ


(Christopher Brown) #3

Hi CJ

Thanks, that makes sense. If I run the printable PDF and go to management. I am getting "Error: URL open failed. Is the server running?" for the report generation. Any ideas?

Thanks

Chris


(CJ Cenizal) #4

Hi Christopher,

So that error message means that a process running on the server couldn't access Kibana. Do you have Kibana behind a proxy, by any chance? That might explain the problem. If so, can you share your reporting.kibanaServer configuration?

If you have Kibana behind a proxy, you'll have to update the configuration to connect to it, possibly just by updating the port. Have a look at https://www.elastic.co/guide/en/reporting/current/reporting-settings.html#reporting-kibana-server-settings for info on all the settings available.

Let me know how it goes!

Thanks,
CJ


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.