Kibana - Request Timeout after 30000ms at /usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:355:15

Fresh installment of Kibana (On redhat 7.6 (64bit) via yum) starts, but is restarting every minute. Before it restarted every 5 seconds, but i fixed it after changing /etc/fstab to allow noexec on /var cause it is needed for /var/lib/kibana/headless_shell-linux/headless_shell.

I tried starting Kibana by command instead of systemctl to see full logs:
/usr/share/kibana/bin/kibana -c /etc/kibana/kibana.yml

It gives me output:

  log   [14:59:49.784] [info][status][plugin:kibana@undefined] Status changed from uninitialized to green - Ready 
(...)[data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.514] [error][status][plugin:graph@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.514] [error][status][plugin:spaces@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.514] [error][status][plugin:security@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.515] [error][status][plugin:searchprofiler@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.515] [error][status][plugin:ml@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.515] [error][status][plugin:tilemap@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.515] [error][status][plugin:watcher@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.516] [error][status][plugin:grokdebugger@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.516] [error][status][plugin:logstash@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.516] [error][status][plugin:beats_management@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.516] [error][status][plugin:maps@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.517] [error][status][plugin:index_management@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.517] [error][status][plugin:index_lifecycle_management@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.517] [error][status][plugin:rollup@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.517] [error][status][plugin:remote_clusters@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.517] [error][status][plugin:cross_cluster_replication@7.1.1] Status changed from yellow to red - [data] Elasticsearch cluster did not respond with license information. 
  log   [14:59:50.901] [warning][browser-driver][reporting] Enabling the Chromium sandbox provides an additional layer of protection. 
  log   [14:59:50.903] [warning][reporting] Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failing on restart, please set xpack.reporting.encryptionKey in kibana.yml 
  log   [14:59:50.919] [error][status][plugin:reporting@7.1.1] Status changed from uninitialized to red - [data] Elasticsearch cluster did not respond with license information. 
 error  [15:00:20.514] [warning][process] UnhandledPromiseRejectionWarning: Error: Request Timeout after 30000ms 
    at /usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:355:15 
    at Timeout.<anonymous> (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:384:7) 
    at ontimeout (timers.js:436:11) 
    at tryOnTimeout (timers.js:300:5) 
    at listOnTimeout (timers.js:263:5) 
    at Timer.processTimers (timers.js:223:10) 
    at emitWarning (internal/process/promises.js:81:15) 
    at emitPromiseRejectionWarnings (internal/process/promises.js:120:9) 
    at process._tickCallback (internal/process/next_tick.js:69:34) 
 error  [15:00:20.515] [warning][process] Error: Request Timeout after 30000ms 
    at /usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:355:15 
    at Timeout.<anonymous> (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:384:7) 
    at ontimeout (timers.js:436:11) 
    at tryOnTimeout (timers.js:300:5) 
    at listOnTimeout (timers.js:263:5) 
    at Timer.processTimers (timers.js:223:10) 
  log   [15:00:20.908] [warning][reporting] Could not retrieve cluster settings, because of Request Timeout after 30000ms 
  log   [15:00:20.940] [warning][task_manager] PollError Request Timeout after 30000ms 
  log   [15:00:20.942] [warning][maps] Error scheduling telemetry task, received NotInitialized: Tasks cannot be scheduled until after task manager is initialized! 
  log   [15:00:20.943] [warning][telemetry] Error scheduling task, received NotInitialized: Tasks cannot be scheduled until after task manager is initialized! 

I want Kibana to start without failing.

Kibana.yml:

    server.port: 5601
    server.host: "xxx.xx.xx.x"
    server.name: "elk-log-kibana"
    elasticsearch.hosts: "http://localhost:9200"
    server.basePath: "/kibana"
    server.rewriteBasePath: true

elasticsearch.yml:

    cluster.name: elk-log-elasticsearch    
    path.data: /var/lib/elasticsearch
    path.logs: /var/log/elasticsearch
    http.port: 9200
    network.host: 0.0.0.0
    discovery.seed_hosts: 127.0.0.1

Elasticsearch works fine:

curl -v http://localhost:9200 
* About to connect() to localhost port 9200 (#0) 
*   Trying ::1... 
* Connected to localhost (::1) port 9200 (#0) 
> GET / HTTP/1.1 
> User-Agent: curl/7.29.0 
> Host: localhost:9200 
> Accept: */* 
> 
< HTTP/1.1 200 OK

Hello @Kamil_Stars

Which license are you trying to use? https://www.elastic.co/subscriptions

It sounds like the license is misconfigured. Fixing it should resolve this error.

It is fresh install from RPM files - so by default i think it is basic license.
The machine i installed Kibana on has no access to the internet.
I can not access Kibana page: https://www.elastic.co/guide/en/kibana/master/managing-licenses.html
How can i manage license from terminal?

I get following error in ES:

[2019-06-06T13:24:36,553][WARN ][o.e.c.c.ClusterFormationFailureHelper] [someHostname] master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and [cluster.initial_master_nodes] is empty on this node: have discovered ; discovery will continue using [127.0.0.1:9300] from hosts providers and [{someHostname}{2pRW1ysSQJSd64RDY1HGQg}{90IP20l0RTW6gcqTrQz0Yg}{SomeIp}{SomeIp:9300}{ml.machine_memory=16657784832, xpack.installed=true, ml.max_open_jobs=20}] from last-known cluster state; node term 0, last-accepted version 0 in term 0
[2019-06-06T13:24:37,001][DEBUG][o.e.a.a.i.t.p.TransportPutIndexTemplateAction] [someHostname] no known master node, scheduling a retry
[2019-06-06T13:24:37,415][DEBUG][o.e.a.a.c.s.TransportClusterStateAction] [someHostname] no known master node, scheduling a retry
[2019-06-06T13:24:37,416][DEBUG][o.e.a.a.i.t.g.TransportGetIndexTemplatesAction] [someHostname] no known master node, scheduling a retry
[2019-06-06T13:24:40,401][WARN ][r.suppressed ] [someHostname] path: /.reporting-/_search, params: {index=.reporting-}
org.elasticsearch.cluster.block.ClusterBlockException: blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized];
at org.elasticsearch.cluster.block.ClusterBlocks.globalBlockedException(ClusterBlocks.java:191) ~[elasticsearch-7.1.1.jar:7.1.1]

EDIT:
Changing ES to this config - make it run well:

        cluster.name: elk-log-elasticsearch    
        path.data: /var/lib/elasticsearch
        path.logs: /var/log/elasticsearch
        http.port: 9200
        network.host: 0.0.0.0
        node.master: true
        node.data: true
        node.name: "xyz"
        cluster.initial_master_nodes: "xyz"

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.