Kibana scripted fields and permissions


(Frances Buontempo) #1

I recently installed X-Packs (using 5.2 for now)

  • the elastic user seems to be able to add script in kibana under Manage Index | Scripted fields, but another user, with a role I made, gets:

"Scripting disabled: All inline scripting has been disabled in Elasticsearch. You must enable inline scripting for at least one language in order to use scripted fields in Kibana."

I've tried adding script.inline: true to elastic's yaml and bounced it, but still get the error.
Do I need to add a permission to the user role? If so what?


(Matt Bargar) #2

It shouldn't be per user, you could try running a script query with Kibana's devtools or curl as a super user to confirm.

What do you see in the script section of the response to <elasticsearch-host>:<port>/_cluster/settings?include_defaults


(Frances Buontempo) #3

Just this:

"script":{"cache":{"max_size":"100","expire":"0ms"},

It does seem to work now, but I also enabled "manage cluster index" in the user's role.
That might be coincidental... I'm not clear what each of the roles mean. (Or what I'm doning!)


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.