Enable inline scripting (painless) to use scripted fields in kibana


(Sylvio de cezare) #1

Hi when trying to write scripted field in kibana i've got an error that says :

Scripting disabled: All inline scripting has been disabled in Elasticsearch. You must enable inline scripting for at least one language in order to use scripted fields in Kibana

i need to use the default painless language what changes should i make in elasticsearch.yml file

thank you!


(Felix Stürmer) #2

Hi @cilzzz,

painless scripting should be enabled by default. You can try to explicitly enable inline scripting by setting:

script.allowed_types: inline

(Sylvio de cezare) #3

thank you !


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.