Kibana Server Not Ready

I have installed Elastic and Kibana 6.5.4, I have also installed SearchGuard on it. I can verify elasticsearch is working by doing a CURL to it. I issue the kibana service start and it shows started. In the browser I get Kibana Server Not Ready yet. There is no errors in the log files. If I list the indices in elasticsearch I dont see a .kibana index. Its very weird. Any help would be appreciated.

Kibana does not generate the .kibana index on start-up. The index is created the first time something is written to it. Did Kibana start prior to installing search guard?

Just checked and to my surprise it does not!

Bump. So I have confirmed that installation of Kibana 6.5.4 doesnt work. Search Guard and xPack is disabled. No error in the log file but keeps saying Kibana is not ready.

Actually, we do create the Kibana index on start. If your seeing a Kibana is not ready message, more than likely it's due to Kibana not being able to connect to Elasticsearch. Are you seeing any Kibana logs related to this?

Nope. All logs are clean.

Can you please provide the Kibana logs?


I believe the culprit is searchguard plugin optimization. The process is never completed in your logs. I have faced this issue a few times. Could you perform these two steps?

  1. Kill Kibana and restart it, see if this works out. If not, proceed to step two.
  2. Start it after uninstalling the searchguard plugin

What are the logs in both these instances?

It could very well be. Hwoever SearchGuard folks are saying that its a bug in Kibana that the optimization of the plugin never finishes and want us to open a issue with Elastic. Hence they recommend installing with no-optimization. Any thoughts on that while I try uninstalling SG?

Yes. It is, and it is being targeted to be fixed by version 7 if I am not wrong.

But, in my experience, a clean restart of Kibana finishes the optimization process in around 3-5 minutes. Like, when I recently upgraded to Kibana 6.5.4, the optimization process was stuck during plugin installation. I aborted that process and performed a restart of the Kibana service. During the startup, the service completed the optimization in 3 minutes.

I have tried waiting a LONG time and it still keeps saying server not ready for me unfortunately


What version of Kibana? What is the OS and are you running it from a zip or a deb or rpm package?

Centos 7 and rpm package

I even tried a older version than 6.5.4 same issue. I know 6 works. I have it configured.

Have you tried running the optimize task manually?

Also, ensure that Kibana can connect to elasticsearch before running this. Ensure that the searchguard settings are updated in kibana.yml.

Running it right now this is whats happening


How long should I wait on it? Its continuing with this


Waiting for about 20 mins on that last line 16:41:59.599 now...