Kibana Service Not Stopping

I am having an odd issue when I type sercive kibana stop in my CentOS7 environment it says kibana stopped by when I run ps -ax | grep kibana it still shows up. If I try to kill the PID it starts a new pid. If I try to restart kibana, it says another instance of kibana is already running on 5601. Any suggestions?

Hey @adwaitjoshi,

Can you please provide a little bit more info:

  • What is Kibana version you use?
  • What is the content of your systemd service file?
  • How do you run Kibana exactly?
  • Can you paste the full output of ps -ax | grep kibana?

Also please try to run Kibana with logging.vervose: true and see if you notice anything suspicious in the output.


I am using the latest 6.3

service kibana start/stop/restart


Thanks a lot!

when you do cat /var/run/ is you pid the same that the one who is running ? I think I had quite the same issue then yours my issue

Looks like the is the issue. How did you resolve it? Just uncomment the line in kibana.yml?

Try to change the pid with vi or nano and put the same pid then your running Kibana and go to yourip:5601
and show me wath are in you Kibana logs cat /var/log/kibana/kibana.stderr

So if I delete the file manually and start kibana it starts with no errors. The pid line in .yml is commented out. And for whatever reason now the pid of the process and pid file match! May be it got solved? I dont know

And when you restart Kibana it works fine ?

Now yes!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.