Kibana startup failing after upgrading to Alpha 2


(Mike Wurtz) #1

From the kibana logs:

log [21:34:55.708] [error][status][plugin:reporting] Status changed from uninitialized to red - Command failed: tar jxf /opt/kibana/installedPlugins/x-pack/.phantom/phantomjs-1.9.8-linux-x86_64.tar.bz2 tar (child): bzip2: Cannot exec: No such file or directory tar (child): Error is not recoverable: exiting now tar: Child returned status 2 tar: Error is not recoverable: exiting now

The Kibana service is failing to start because of this.. I've verified that the file does exist.. Any help would be appreciated.


(Tim Sullivan) #2

Can you try:

  1. Make sure you have the bzip2 executables installed on the machine:
  • which bzip2
  • which bunzip2
  1. Check the file permissions on the file that the process is trying to read:
    ls -la installedPlugins/x-pack/.phantom
    That will also list the permissions of the parent directory, where the decompressed files will need to be created.

If bzip is not installed on the machine, it will need to be. If it is a permissions issue, the installedPlugins directory ownership will need to be recursively changed to the user that runs the Kibana process.


(Mike Wurtz) #3

Server was missing bzip2.. Works now.. Thanks.


(AJ-2) #4

Hi, I got a similar error on alpha3.

plugin:reporting
http://pastebin.com/2D0Q5n3h

/opt/kibana/installedPlugins/x-pack/.phantom$ ls -la
total 42564
drwxr-xr-x 2 root root     4096 Jun  8 14:58 .
drwxr-xr-x 6 root root     4096 Jun  8 14:58 ..
-rw-r--r-- 1 root root        0 Jun  8 14:58 .empty
-rw-r--r-- 1 root root 13517724 Jun  8 14:58 phantomjs-1.9.8-linux-i686.tar.bz2
-rw-r--r-- 1 root root 13163325 Jun  8 14:58 phantomjs-1.9.8-linux-x86_64.tar.bz2
-rw-r--r-- 1 root root  9408114 Jun  8 14:58 phantomjs-1.9.8-macosx.zip
-rw-r--r-- 1 root root  7467786 Jun  8 14:58 phantomjs-1.9.8-windows.zip

(Tim Sullivan) #5

This will be fixed in a future version of X-Pack, so that the Reporting plugin won't rely on a system-installed bzip2 on Linux.


(Tim Sullivan) #6

AJ_2, your error looks to be a different type, a permissions error. That looks related to these issues:



(AJ-2) #7

I'm playing a bit more with this and I figured out the problem with permissions might be broader.

I added: logging.dest: /var/log/kibana.log to kibana.yml. That prevents kibana from starting. I fails with a permition error: Error: EACCES: permission denied, open '/var/log/kibana.log'
In case it is expected behavior that the log file should be owned by a kibana user it should state so in the comments. This also makes me wonder if any other configs are subjected to the same problems (pid files, certificates etc.).

I tried to run it "manually" with sudo bin/kibana and the permissions problems (reporting plugin, custom log file) went away. So I came to the conclusion that sudo service kibana start just runs it without the necessary permissions to actually work.

I've installed it as a deb package on a Ubuntu 16 OS.


(system) #8