Kibana startup failure in Windows

Hi All

I downloaded Kibana 7.13.4 zip file and extracted in windows. I started kibarna.bat in command prompt. I am getting the following error. Any help is appreciated.

log [11:02:36.548] [fatal][root] Error: Cannot find module './persistence_google_workspace_api_access_granted_via_domain_wide_delegation_of_authority.json'
Require stack:

  • C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\lib\detection_engine\rules\prepackaged_rules\index.js
  • C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\lib\detection_engine\rules\get_prepackaged_rules.js
  • C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\lib\detection_engine\routes\rules\add_prepackaged_rules_route.js
  • C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\routes\index.js
  • C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\plugin.js
  • C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\index.js
  • C:\softwares\elk\kibana-7.13.4\x-pack\plugins\lists\server\siem_server_deps.js
  • C:\softwares\elk\kibana-7.13.4\x-pack\plugins\lists\server\routes\create_endpoint_list_item_route.js
  • C:\softwares\elk\kibana-7.13.4\x-pack\plugins\lists\server\routes\index.js
  • C:\softwares\elk\kibana-7.13.4\x-pack\plugins\lists\server\routes\init_routes.js
  • C:\softwares\elk\kibana-7.13.4\x-pack\plugins\lists\server\plugin.js
  • C:\softwares\elk\kibana-7.13.4\x-pack\plugins\lists\server\index.js
  • C:\softwares\elk\kibana-7.13.4\src\core\server\plugins\plugin.js
  • C:\softwares\elk\kibana-7.13.4\src\core\server\plugins\discovery\plugins_discovery.js
  • C:\softwares\elk\kibana-7.13.4\src\core\server\plugins\discovery\index.js
  • C:\softwares\elk\kibana-7.13.4\src\core\server\plugins\plugins_service.js
  • C:\softwares\elk\kibana-7.13.4\src\core\server\plugins\index.js
  • C:\softwares\elk\kibana-7.13.4\src\core\server\server.js
  • C:\softwares\elk\kibana-7.13.4\src\core\server\root\index.js
  • C:\softwares\elk\kibana-7.13.4\src\core\server\bootstrap.js
  • C:\softwares\elk\kibana-7.13.4\src\core\server\index.js
  • C:\softwares\elk\kibana-7.13.4\src\cli\serve\serve.js
  • C:\softwares\elk\kibana-7.13.4\src\cli\cli.js
  • C:\softwares\elk\kibana-7.13.4\src\cli\dist.js
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:902:15)
    at Module.Hook._require.Module.require (C:\softwares\elk\kibana-7.13.4\node_modules\require-in-the-middle\index.js:61:29)
    at require (internal/modules/cjs/helpers.js:92:18)
    at Object. (C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\lib\detection_engine\rules\prepackaged_rules\index.js:732:119)
    at Module._compile (internal/modules/cjs/loader.js:1085:14)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1114:10)
    at Module.load (internal/modules/cjs/loader.js:950:32)
    at Function.Module._load (internal/modules/cjs/loader.js:790:14)
    at Module.require (internal/modules/cjs/loader.js:974:19)
    at Module.Hook._require.Module.require (C:\softwares\elk\kibana-7.13.4\node_modules\require-in-the-middle\index.js:80:39)
    at Module.Hook._require.Module.require (C:\softwares\elk\kibana-7.13.4\node_modules\require-in-the-middle\index.js:80:39)
    at Module.Hook._require.Module.require (C:\softwares\elk\kibana-7.13.4\node_modules\require-in-the-middle\index.js:80:39)
    at Module.Hook._require.Module.require (C:\softwares\elk\kibana-7.13.4\node_modules\require-in-the-middle\index.js:80:39)
    at Module.Hook._require.Module.require (C:\softwares\elk\kibana-7.13.4\node_modules\require-in-the-middle\index.js:80:39)
    at require (internal/modules/cjs/helpers.js:92:18)
    at Object. (C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\lib\detection_engine\rules\get_prepackaged_rules.js:20:26) {
    code: 'MODULE_NOT_FOUND',
    requireStack: [
    'C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\lib\detection_engine\rules\prepackaged_rules\index.js',
    'C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\lib\detection_engine\rules\get_prepackaged_rules.js',
    'C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\lib\detection_engine\routes\rules\add_prepackaged_rules_route.js',
    'C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\routes\index.js',
    'C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\plugin.js',
    'C:\softwares\elk\kibana-7.13.4\x-pack\plugins\security_solution\server\index.js',
    'C:\softwares\elk\kibana-7.13.4\x-pack\plugins\lists\server\siem_server_deps.js',
    'C:\softwares\elk\kibana-7.13.4\x-pack\plugins\lists\server\routes\create_endpoint_list_item_route.js',
    'C:\softwares\elk\kibana-7.13.4\x-pack\plugins\lists\server\routes\index.js',
    'C:\softwares\elk\kibana-7.13.4\x-pack\plugins\lists\server\routes\init_routes.js',
    'C:\softwares\elk\kibana-7.13.4\x-pack\plugins\lists\server\plugin.js',
    'C:\softwares\elk\kibana-7.13.4\x-pack\plugins\lists\server\index.js',
    'C:\softwares\elk\kibana-7.13.4\src\core\server\plugins\plugin.js',
    'C:\softwares\elk\kibana-7.13.4\src\core\server\plugins\discovery\plugins_discovery.js',
    'C:\softwares\elk\kibana-7.13.4\src\core\server\plugins\discovery\index.js',
    'C:\softwares\elk\kibana-7.13.4\src\core\server\plugins\plugins_service.js',
    'C:\softwares\elk\kibana-7.13.4\src\core\server\plugins\index.js',
    'C:\softwares\elk\kibana-7.13.4\src\core\server\server.js',
    'C:\softwares\elk\kibana-7.13.4\src\core\server\root\index.js',
    'C:\softwares\elk\kibana-7.13.4\src\core\server\bootstrap.js',
    'C:\softwares\elk\kibana-7.13.4\src\core\server\index.js',
    'C:\softwares\elk\kibana-7.13.4\src\cli\serve\serve.js',
    'C:\softwares\elk\kibana-7.13.4\src\cli\cli.js',
    'C:\softwares\elk\kibana-7.13.4\src\cli\dist.js'
    ]

Did you wait for the package to completely unzip before running kibana.bat?
I get a similar error when trying to run Kibana without waiting for the whole zip to be unpackaged.

I just downloaded 7.13.4 zip package and got no such error.
Try downloading it again and unzipping it again. It's possible you just had a corrupt download.

1 Like

It worked. You gave a super clue. Thanks a lot. You saved a lot of my time. Appreciate your quick response.

1 Like