Kibana Status RED - {"code":"ECONNRESET"}


#1

I was trying to access Kibana and I've got redirected to page with following message in red:

plugin:elasticsearch@6.2.4 {"code":"ECONNRESET"}

Kibana's log:

kibana-re-custom | {"type":"log","@timestamp":"2018-06-19T14:57:11Z","tags":["error","elasticsearch","admin"],"pid":1,"message":"Request error, retrying\nGET http://esc1:9200/_nodes?filter_path=nodes.*.version%2Cnodes.*.http.publish_address%2Cnodes.*.ip => socket hang up"}

yet when I looked at elasticsearch log, there is no errors and it seems to be working just fine. I restarted both of them elasticsearch and kibana and everything is back to normal.

Please advise.


(Bhavya R M) #2

Hi,

is your kibana up now?

Thanks,
Bhavya


#3

As I stated earlier after restart both Elasticsearch and Kibana everything is back to normal, however I would like figure out what exactly went wrong and what can I do to prevent this in future or at least do better troubleshooting to help you guys figure out an actual cause...


(Larry Gregory) #4

Hi @alexus,

It sounds like you might be experiencing the same problem that another user reported. His solution was to put a proxy in between Kibana and Elasticsearch, but an easier solution for you might be to set the elasticsearch.healthcheck.delay property to a higher value (see linked issue).

If this is in fact what you are experiencing, then I recommend voting for https://github.com/elastic/kibana/issues/14163, which solves the underlying problem.


#5

I appreciate your reply. I follow Using Kibana in a production environment | Kibana User Guide (I don't see anything proxy related)

I'm more than willing to experiment with elasticsearch.healthcheck.delay value, however I can't find what's default value and how high should I increase it too?

Please advise.


(Larry Gregory) #6

You're absolutely right, setting up a proxy is outside the scope of that setup document. I wouldn't advise going down that route right now, until we've exhausted other options.

The elasticsearch.healthcheck.delay defaults to 2500, which is 2.5 minutes (it expects milliseconds). I would start by doubling that to 5000 (5 minutes), and see if that alleviates your symptoms. If not, try bumping that up to 8 or 10 minutes. If you're having issues after that, then there could be something else going on


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.