Kibana stores "Jan 2001 - now" instead of configured time in dashboard

I don't understand if this is something I am doing wrong or if that's an issue in Kibana. I've created a new space, with a visualization and a dashboard. It's showing download rate for which we have data several times a day so I've chosen "Last Week" as the configured time for the dashboard.

It worked and recently, whenver I start a fresh session, the dashboard is showing me the last 23 years, specifically from Jan 2001 at midnight to now. If I attempt to change the date and save the dashboard, it always restore to that specific time. I tried save as, same result.

We're on elasticcloud with 8.11.3. Any idea what might go wrong?

When the error occurs, the browser console shows:

Deprecation warning: value provided is not in a recognized RFC2822 or ISO format. moment construction falls back to js Date(), which is not reliable across all browsers and versions. Non RFC2822/ISO date formats are discouraged. Please refer to for more info.

To solve this problem, we have:

  • upgraded from 8.11.3 to 8.12.2
  • disabled "store time with dashboard" in settings and saved
  • set the time to something valid
  • enabled "store time with dashboard" in settings and saved

It all works now.

1 Like

Great to hear! :wink:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.