[Kibana Timelion] - Cannot apply Dashboard filter on Timelion functions

Hi there,
Thanks in advance for your help

I have written a couple of timelion functions and all of them request the same index-pattern, they just differ by their q='' filter and metric.

However, from a dashboard, where I added this timelion visualization, I want the user to be able to apply a global filter on it e.g selecting a specific ID for example ...

I read on forums that kibana=true into .es() should do the trick but I've got unlucky so far ...

I tried either kibana=true, kibana=false and without it. Also tried different ways of applying the filter on the dashboard (control, KQL query and via the classic "Add filter"...)

It actually seems like the filter is not taken into account. Adding or removing it doesn't change anything on my visualization ...

Can someone help please ? I'm using kibana-7.7.0


bump. i'd be interested to know the outcome here. any success Guillaume?

Actually not yet ... been away for a while so didn't get the time to give a serious other shot either
Experiencing the same issue ?

I had just starting using Timelion views.
They are working for me in a dashboard - I can apply filters and they update the timelion views :+1:

Oh ...
Can you please share the kibana version you are using, if you are using kibana=true/false and how do you apply the filters on your dashboards (classic 'apply filter' , control visu,etc.) ?

Many thanks

my kibana=true/false is just the default setting.
I'm using v7.7.1 and I can set filters in the search bar, i.e. "extra_fields.identity : 1004"

Thanks. It turned out that is working for me too now
I'm not sure what changed ... i was probably doing something wrong before

Thanks for your help ! :slight_smile:

Did you have an update to 7.7.1 or something?
I am working also in 7.7.0 and I am facing the exact same problem. All visualisations take the filters and use them except the Timelion Vis.....

Got it...release notes 7.7.1. I have to let someone upgrade kibana on the server :slight_smile:

Timelion graph is not refreshing content after searching or filtering #67023

Oh yes correct :sweat_smile: I'm running 7.8 now !

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.