Timelion kibana='false' option is not working?


#1

I have a very obvious need: computing a ratio between 2 time series.
What I want is that kibana filters (of my dahsboard) only apply on one of the 2 series.

I did the following simple test :
es(index='myindex', q='_type:myDocType', timefield='myDateField', kibana='false')
Then I added some filters in my dahsboard. Each time filters have an effect on my timelion chart...
I tried different syntaxes: kibana='False', kibana=false... no change.

Can anyone help me? Is this feature really implemented? (currenly running Kibana 4,6,2)
Thanks in advance
P.


#2

I did the test with 5.3.2 stack, and that's the same.
Changing kibana flag does not have any impact :frowning:


(Joe Fleming) #3

Can anyone help me? Is this feature really implemented?

I just tried this in a 6.0.0 pre-release, and I see the same thing. It's likely a bug in Timelion. I encourage you to open an issue with the information you posted here in the Kibana repo at https://github.com/elastic/kibana/issues.


(Rashid Khan) #4

false should be all lower case and not be quoted, though the OP says they tried that. I just double checked and it seems to behave as expected. As you can see, the chart in the top right does not change.


(Joe Fleming) #5

Yeah, sure enough, it's working for me as well. Apparently I set it up wrong originally, I forgot to add kibana=false :frowning:

Here, the TImelion graph on the top lacks the setting, the bottom one is set, and you can see it does not react to the query that is applied.


#6

Yes kibana=false is the right syntax :slight_smile:
I reached the same conclusion yesterday but too late to post it
Many thanks for your help.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.