Timelion not working


(Carlos Vega Moreno) #1

I just installed timelion but no data is shown when I try to draw metrics. Is not my first time using timelion and I did not change any conf file, the datasource index is "_all". Nothing shows.

I then enabled the initial tutorial of timelion on kibana and added the proper timestamp field to the config file, still:

"Could not validate elasticsearch config: Unknown error. "

And nothing shows. Any ideas? Permissions look ok to me. I even gave 777 permissions as a try, without a change.


(Lee Drengenberg) #2

Hi Carlos,

Which version of Kibana are you on? And about when did you install Timelion?

Regards,
Lee


(Carlos Vega Moreno) #3

4.4.1 and I just installed it and removed again and try it again haha. Nothing new yet :confused:


(Lee Drengenberg) #4

Hi Carlos,

But you are getting data OK in kibana?

I also have kibana 4.4.1 with timelion installed and its working OK for me. I have the default timelion.json configuration (see below).

{
  "quandl": {
    "key": ""
  },
  "es": {
    "timefield": "@timestamp",
    "default_index": "_all",
    "allow_url_parameter": false
  },
  "graphite": {
    "url": "https://www.hostedgraphite.com/UID/ACCESS_KEY/graphite"
  },
  "default_interval": "1h",
  "max_buckets": 2000
}

Did you install timelion like this?
./bin/kibana plugin -i elastic/timelion


Anyone install plugins successful on K4.4.1?
(Lee Drengenberg) #5

If you are getting data in kibana, then its likely a problem with your timefield configuration.


(Carlos Vega Moreno) #6

I installed it like that. Kibana is OK and I'm using a timestamp field from a different index. I just copied the timelion conf file from a working set. I tried with different indices with different date fields. Nothing worked :frowning:

There's an issue opened here:


(system) #7