Kibana TLS settings using "server.ssl.keystore.path" not working

Hi,

I was trying to set up TLS for kibana (v-7.4.2) using a keystore. I have configured the keystore using "server.ssl.keystore.path" and "server.ssl.keystore.password" as per this - https://www.elastic.co/guide/en/kibana/current/configuring-tls.html

However, am getting "FATAL Error: [server.ssl.keystore]: definition for this key is missing" error while starting the Kibana.

I have tried to extract the key and certs from the same keystore and configured them seperately using "server.ssl.certificate" and "server.ssl.key" properties and it was working fine.

Did I miss anything in my keystore based configuration? Would like to use the keystore based configuration instead of keeping key and cert separately.

Appreciate any inputs to understand what went wrong.

Thanks in advance

Is your keystore encrypted? How you provided the appropriate password for decryption?

I have provided password using "server.ssl.keystore.password" property in kibana.yml. Tried to add the same through the kibana-keystore as well.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.