Kibana troubles with x-pack and infinity optimizing proccess

ES v 6.3
Kibana 6.3.1

When i use curl - it is OK.

curl https://server:443
{
  "name" : "NAME",
  "cluster_name" : "868651433674:name",
  "cluster_uuid" : "UUID",
  "version" : {
    "number" : "6.3.1",
    "build_flavor" : "oss",
    "build_type" : "zip",
    "build_hash" : "e6df130",
    "build_date" : "2018-08-01T07:23:36.254471Z",
    "build_snapshot" : false,
    "lucene_version" : "7.3.1",
    "minimum_wire_compatibility_version" : "5.6.0",
    "minimum_index_compatibility_version" : "5.0.0"
  },
  "tagline" : "You Know, for Search"
}

But if i start Kibana with settings:

sed /^#/d /etc/kibana/kibana.yml

xpack.security.enabled: false
server.port: 5601
server.host: "x.x.x.x"
elasticsearch.url: "https://server:443"

Kibana started, but hangs up with (i wait few hours, but no changes):
"Optimizing and caching bundles for kibana"

If i comment the line with
#xpack.security.enabled: false

i cant login with kibana:

logs:

Jan 17 09:41:02 ip-X.X.X.X kibana: {"type":"log","@timestamp":"2019-01-17T09:41:02Z","tags":["license","warning","xpack"],"pid":31498,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. Authentication Exception :: {\"path\":\"/_xpack\",\"statusCode\":401,\"response\":\"{\\\"Message\\\":\\\"Your request: '/_xpack' is not allowed.\\\"}\"}"}

Please, could you tell me, how to login ? :slight_smile:

Hello,

I tried to do exactly the same as your config in my local and I got stuck too. One of the things which is puzzling me about your config is you disabling xpack security? Why so?

Also did you generate password using bin/Elasticsearch-setup-passwords interactive?

Anyways - I am going to talk to our ops team and keep you posted.

Thanks,
Bhavya

It looks like you are trying to use the OSS distribution of Elasticsearch together with the default distribution of Kibana. I think you need to align and use the same distribution for both components.

2 Likes

Ah I missed that :slight_smile: Thanks Christian!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.