Kubernetes Baremetal Configuration

Hi ES community. I'm trying to run an elasticsearch cluster on my kubernetes bare-metal setup.

I took some inspiration from here: Running Elasticsearch on Kubernetes

& tried to adapt it for my getup, but am not having full success yet.

Please look over my config & let me know where I may be in error. Thank you!

es-client | es-data | es-master | es-svc

I also modified the elasticsearch.yml config file

When I hit the service address from a pod this results:

curl -XGET 'http://elasticsearch.default.svc.kubernetes.local:9200/_cluster/stats?pretty'

{ ... }

 "nodes" : {
"count" : {
  "total" : 1,
  "master_only" : 0,
  "data_only" : 0,
  "master_data" : 0,
  "client" : 0

Can anyone help point me in the correct direction?

I solved the issues on my own. My approach was pretty jacked up, but I had tried vanilla guides to no avail. Turns out one major reason was due to an ongoing (and recently reported) issue surrounding overlay(2)fs and 4+ base images. Built my own image by consolidating the commands of 3 dockerfiles into 1, stored it on my own public repo (with firewalled port), done.

Will make a simple guide later to hopefully help someone out who runs into similar nightmare.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.