Latest stable filebeat version for freebsd missing


(Sai Birada) #1

I am downloading filebeat freebsd binary from https://beats-nightlies.s3.amazonaws.com/index.html?prefix=jenkins/filebeat/ but from here i am getting alpha releases, but i want to use filebeat's latest stable version. Can someone give me the location from where i can download the latest stable filebeat freebsd binary.


(Michael Yu Sha) #2

maybe you can downloading filebeat rpm file from https://download.elastic.co/beats/filebeat/filebeat-1.3.1-x86_64.rpm,it is the latest version


(Sai Birada) #3

Hi Micheal,
This rpm version wont work in freebsd. I tried and it failed with Error: ELF binary type "0" not known.


(Michael Yu Sha) #4

well, i am also not find any version for freebas


(Andrew Kroh) #5

Elastic doesn't provide FreeBSD packages officially. So you won't find FreeBSD packages on the download pages. If you want to run it on FreeBSD then I recommend building from source using the release branch.

The packages located at https://beats-nightlies.s3.amazonaws.com/index.html?prefix=jenkins/filebeat/ are built from the master branch (no stability guarantees) whenever a change is committed. They are published by Jenkins for convenience and testing purposes.


(Sai Birada) #6

Hi andrewkroh,
I tried to clone the repo from the source you gave and ran make in beats/filebeat/ but it ended in failure saying
"../libbeat/scripts/Makefile", line 59: Missing dependency operator
"../libbeat/scripts/Makefile", line 61: Need an operator
"../libbeat/scripts/Makefile", line 64: Missing dependency operator
"../libbeat/scripts/Makefile", line 65: warning: duplicate script for target "ifeq" ignored
"../libbeat/scripts/Makefile", line 66: Need an operator
make: fatal errors encountered -- cannot continue

Procedure followed :
git clone https://github.com/elastic/beats.git
cd beats/filebeat
make

I am using go 1.7.1 version


(Sai Birada) #7

my freebsd version is 8.4 is it that causing the error?


(Andrew Kroh) #8

We use GNU Make. Probably on FreeBSD you need to run gmake instead of make.


(Sai Birada) #9

Yes that worked, Thanks


(system) #10

This topic was automatically closed after 21 days. New replies are no longer allowed.