Lazy optimization takes >100s


(Luca Wintergerst) #1

Hi,

I just tried to give writing kibana plugins a try.

AFter every change I have to wait > 100s for the optimization finishes.

I'm running it on my local laptop (~2y.o, 2,7GHZ core, 16BG RAM, SSD), using Windows (the setup was time consuming and may be the problem. I might just use a linux VM...)

The plugin itself is the one Tim Roes writes in his "Writing Kibana 4 Plugins" blog post.

Is there any way to make it faster?


(Shelby Sturgis) #2

You can try adding a kibana.dev.yml file under the /config directory. Add this to your kibana.dev.yml file:

optimize:
   sourceMaps: '#cheap-source-map' # options -> http://webpack.github.io/docs/configuration.html#devtool
   unsafeCache: true
   lazyPrebuild: false

(Luca Wintergerst) #3

Thanks for the response.

I just tried it real quick. It seems to be working much better now. I will report back in 1-2 days to confirm it once I had time to test it thoroughly.

Luca


(Spencer Alger) #4

Yeah 100s is extraordinary (even when optimizations are not enabled). Are you seeing excessive CPU usage before optimization starts?


(system) #5