License information could not be obtained from Elasticsearch for the [data] cluster

I have installed elasticsearch 7.5.1 and the same version of Kibana.. My es cluster seems fine, but Kibana is not able to connect to the elasticsearch..
Kiabana.yml is as below:

server.port: 5601 "" ""
elasticsearch.hosts: [ "https://<IP of ES instance 1>:443" , "https://<IP of ES instance 2>:443" ]
elasticsearch.username: "<kibana_user>"
elasticsearch.password: "<kibana_user_password>"
server.ssl.enabled: true
server.ssl.key: true
xpack.reporting.kibanaServer.port: 443
xpack.reporting.kibanaServer.protocol: https
elasticsearch.ssl.certificateAuthorities: [ "" ]
elasticsearch.ssl.verificationMode: certificate
logging.dest: /etc/kibana/log/kibana.log

I have tried both kibana_oss and the non_oss, but I get the same error..

Thanks in advance for the suggestions!

Are you running the default distribution of Elasticsearch as well, or the OSS one? Do your Elasticsearch logs contain any license-related entries for when Kibana tries to connect?

If you haven't already, you may want to double-check that everything is fine with your license by running GET /_license on your cluster.

Hi Luke,

Thanks for the reply!

It is a default distribution of Elastic search..

The license detail is as below..



Hi Luke,

Is this something you can help me with?


Hmm, I assume you are able to curl both of your elasticsearch.hosts nodes directly, and they are part of the same cluster, correct? Are you getting anything else in the logs besides "license information could not be obtained"?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.