License is not available

hello , when I use Elasticsearch with kibana they work together but when I add true in Elasticsearch.yml they stop working and I get this message : license is not available


Welcome to our community! :smiley:

What happens when you curl Elasticsearch?

Please don't post pictures of text, logs or code. They are difficult to read, impossible to search and replicate (if it's code), and some people may not be even able to see them :slight_smile:

aa ok .
sudo curl localhost:9200
{"error":{"root_cause":[{"type":"security_exception","reason":"missing authentication credentials for REST request [/]","header":{"WWW-Authenticate":"Basic realm="security" charset="UTF-8""}}],"type":"security_exception","reason":"missing authentication credentials for REST request [/]","header":{"WWW-Authenticate":"Basic realm="security" charset="UTF-8""}},"status":401}

1 Like


You will need to add the username and password that was configured when you enabled security. See Start the Elastic Stack with security enabled | Elasticsearch Guide [8.2] | Elastic

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.