Problem Missing authentication token for REST request

security

(Ivo Geel) #1

Hello everyone,

I just started using ElasticSearch and Kibana and had great experiences so far.
However, I just installed the X-pack and retrieved a 1-year basic license.
When I tried to update the license to my ES and Kibana it gave an error stating:

"error": {
"root_cause": [
{
"type": "security_exception",
"reason": "missing authentication token for REST request [/bank/account/_bulk?pretty%20-d%20%7B%22password%22%20:%20%22mWn4T85RTbTjNx5bpdN6%22%29]",
"header": {
"WWW-Authenticate": "Basic realm="security" charset="UTF-8""
}
}
],
"type": "security_exception",
"reason": "missing authentication token for REST request [/bank/account/_bulk?pretty%20-d%20%7B%22password%22%20:%20%22mWn4T85RTbTjNx5bpdN6%22%29]",
"header": {
"WWW-Authenticate": "Basic realm="security" charset="UTF-8""
}
},
"status": 401

I used the passwords provided by Elastic in the .yml of elasticsearch and kibana.
Also after this, I couldn't see any of the data that I had loaded in before installing the X-pack and license.

Can anyone help me with this issue?

Thanks in advance!

Ivo


(Ioannis Kakavas) #2

Hi,

Please note that the Basic License does not include Security. You can get a comprehensive view of what is included in every subscription tier by visiting this page


(Tim Vernum) #3

When you install x-pack, the default behaviour is for it to automatically generates a trial license for all platinum features. This includes X-Pack security, which it now preventing you from installing your Basic license (which doesn't not include security).

The easiest solution is to disable security in your configuration file, and restart. Add

xpack.security.enabled: false

to your elasticsearch.yml on every node, then you'll be able to install your new 1-year basic license.


(Ivo Geel) #4

Thank you! I hadn't figured that out and it works now.

Ivo


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.