License update error


(Sivabalan N) #1

Hi Team,

Getting below error while updating license.

{
"error": {
"root_cause": [{
"type": "illegal_argument_exception",
"reason": "failed to parse license source"
}],
"type": "illegal_argument_exception",
"reason": "failed to parse license source",
"caused_by": {
"type": "json_parse_exception",
"reason": "Unrecognized token 'sivabalan': was expecting ('true', 'false' or 'null')\n at [Source: org.elasticsearch.transport.netty4.ByteBufStreamInput@3687f98e; line: 1, column: 11]"
}
},
"status": 400
}


(Christian Dahlqvist) #2

Are you by any chance running curl without an @ ahead of the file name? Can you show the exact command you are running?


(Sivabalan N) #3

Hi Christian,

I'm running below command exactly.

curl -XPUT -u uname:pwd 'http://localhost:9200/_xpack/license' -H "Content-Type: application/json" -d sivabalan-nagarajan-2327c0fa-f56b-443a-a3d6-abef7ecf2220-v5.json


(Christian Dahlqvist) #4

Yes, you are missing the @ ahead of the file name, which means that curl does not pass the content of the file. Try this:

curl -XPUT -u uname:pwd 'http://localhost:9200/_xpack/license' -H "Content-Type: application/json" -d @sivabalan-nagarajan-2327c0fa-f56b-443a-a3d6-abef7ecf2220-v5.json


(Sivabalan N) #5

Find the response below.

{
"acknowledged": false,
"license_status": "valid",
"acknowledge": {
"message": "This license update requires acknowledgement. To acknowledge the license, please read the following messages and update the license again, this time with the "acknowledge=true" parameter:",
"watcher": ["Watcher will be disabled"],
"security": ["The following X-Pack security functionality will be disabled: authentication, authorization, ip filtering, and auditing. Please restart your node after applying the license.", "Field and document level access control will be disabled.", "Custom realms will be ignored."],
"monitoring": ["Multi-cluster support is disabled for clusters with [BASIC] license. If you are\nrunning multiple clusters, users won't be able to access the clusters with\n[BASIC] licenses from within a single X-Pack Kibana instance. You will have to deploy a\nseparate and dedicated X-pack Kibana instance for each [BASIC] cluster you wish to monitor.", "Automatic index cleanup is locked to 7 days for clusters with [BASIC] license."],
"graph": ["Graph will be disabled"],
"ml": ["Machine learning will be disabled"]
}
}

Do I need to restart the node now ?


(Tim Vernum) #6

No, the key is in this part of the message:

This license update requires acknowledgement. To acknowledge the license, please read the following messages and update the license again, this time with the "acknowledge=true" parameter:

You need to read and understand the message (about features being disabled) and then run this:

curl -XPUT -u uname:pwd 'http://localhost:9200/_xpack/license?acknowledge=true' -H "Content-Type: application/json" -d @sivabalan-nagarajan-2327c0fa-f56b-443a-a3d6-abef7ecf2220-v5.json

(Sivabalan N) #7

Thanks Tim :slight_smile:


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.