Limit results in Saved Searches

Hello! Tell me how in kibana 6.4.0 change the display limit for the number of output lines in the Saved Searches?


the only exposed configuration is discover:sampleSize in advanced settings. By default 500 documents will be pulled down with a page size of 50. This will keep the page size at 50, but let you load more (or less) documents. Would this work for you?

Unfortunately, when using this parameter in advanced settings

discover:sampleSize = 5000

, it does not display more than 50 rows in Saved searches under the user kibana_dashboard_only_user

Ah gotcha. It looks like the max of 50 is hardcoded, ref. it would be fairly straightforward to make it configurable but would require an enhancement request.

Is this a bug? Previously, you could remove this limit in the settings.

How fix now?

This probably is an enhancement request. You can file here:


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.