Listening only on local interface


(rjkerkhoff) #1

I want to run elasticsearch only on the local interface so i read
the documentation and started the service with 'elasticsearch -f -
Dnetwork.host=local'. At this point it correctly uses the ipv4 local
interface but it's still opening up to the external interface over
ipv6. Is this correct behaviour or am i'm missing something?
Is there a way to disable this ipv6 listener?

Thanks in advance!


(Shay Banon) #2

local does not mean the just the local interface, it means using what the
computers states is the local inet address. You can set it to 127.0.0.1 or
localhost.

On Sat, Sep 25, 2010 at 5:28 PM, rjk rjkerkhoff@gmail.com wrote:

I want to run elasticsearch only on the local interface so i read
the documentation and started the service with 'elasticsearch -f -
Dnetwork.host=local'. At this point it correctly uses the ipv4 local
interface but it's still opening up to the external interface over
ipv6. Is this correct behaviour or am i'm missing something?
Is there a way to disable this ipv6 listener?

Thanks in advance!


(system) #3