Load one dashboard instead of all Filebeat default dashboards

Hopefully I'm just going about this all wrong. I've tried to use set.dashboards.file in the dashboards section of the filebeat.yml to load just the IIS dashboard. First I tried to export the Filebeat-iis.json in kibana and zip the file then load it using the below config. Then I tried just using the json file. Below are the configs I used in the filebeat.yml.

set.dashboards.file: /usr/share/filebeat/kibana/6/dashboard/Filebeat-iis.json.zip

Then I tried to load the json.

set.dashboards.file: /usr/share/filebeat/kibana/6/dashboard/Filebeat-iis.json

I don't need to load all the default dashboards. Both above settings do not work. Any help much appreciated. Running 6.7.1 ELK and Filebeat.

This is my dashboard config
#============================== Dashboards =====================================

These settings control loading the sample dashboards to the Kibana index. Loading

the dashboards is disabled by default and can be enabled either by setting the

options here, or by using the -setup CLI flag or the setup comman

#setup.dashboards.enabled: true

The URL from where to download the dashboards archive. By default this URL

has a value which is computed based on the Beat name and version. For released

versions, this URL points to the dashboard archive on the artifacts.elastic.co

website.

#setup.dashboards.url:
set.dashboards.file: /usr/share/filebeat/kibana/6/dashboard/Filebeat-iis.json.zip

Any help much appreciated.

Hello, You can use setup with --module to only load things from a single module.

Hey, thanks for the reply! I ran
filebeat setup --modules iis
It still loaded all the default dashboards for Filebeat.
I tried they filebeat system module as well.
I also tried this
filebeat setup --dashboards --modules iis
Still loaded all the default dashboards.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.