Login is currently disabled after security on


(Jason Y) #1

now I am trying to initiate x-pack Security but seeing some errors.

in Kibana: (i am seeing below error while screen showing "login" feature)
"Login is currently disabled. Administrators should consult the Kibana logs for more details."

I looked at the kibana log what the kibana page advised to me, and below errors were observed.

{"type":"log","@timestamp":"2018-10-06T06:30:56Z","tags":["license","warning","xpack"],"pid":8247,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } :: {"path":"/_xpack","statusCode":401,"response":"{\"error\":{\"root_cause\":[{\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}","wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}"}
{"type":"log","@timestamp":"2018-10-06T06:31:26Z","tags":["license","warning","xpack"],"pid":8247,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } :: {"path":"/_xpack","statusCode":401,"response":"{\"error\":{\"root_cause\":[{\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}","wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}"}
{"type":"log","@timestamp":"2018-10-06T06:31:56Z","tags":["license","warning","xpack"],"pid":8247,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } :: {"path":"/_xpack","statusCode":401,"response":"{\"error\":{\"root_cause\":[{\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}","wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}"}
{"type":"log","@timestamp":"2018-10-06T06:32:26Z","tags":["license","warning","xpack"],"pid":8247,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security_exception] missing authentication token for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } :: {"path":"/_xpack","statusCode":401,"response":"{\"error\":{\"root_cause\":[{\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security_exception\",\"reason\":\"missing authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}","wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}"}

what i did before i experienced above errors were as below.

  1. xpack.security.enabled: true
  2. set password for "elastic","kibana" and "logstash-system" users, then put passwords to ELK configurations.
  3. restarted ELK.

Please advice what i should do to resolve.

Please don't tell me to security setting to "off". I am trying to make this works. :frowning:

Thank you!


BadResponseCodeError error=>"Got response code '401'
(Ioannis Kakavas) #2

Hi ,

Have you read our documentation? It looks like you are on the right track, you just need to configure kibana. Please start from here


(Jason Y) #3

thank you for your reply, ikakavas. the problem was solved by below solution what you advised.

  • i removed elasticsearch.username and elasticsearch.password lines from kibana.yml.
  • i created keystore then add username and password there.
  • restarted kibana. "login is currently disabled" was gone on the kibana login page. i typed username and password which just created in the keystore. logged in successfully! :slight_smile:

thanks alot!


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.